Upgrade gescheitert

Wie vielleicht so mancher bemerkt hat, war dieses Blog heute tagsüber nicht erreichbar, hatte Fehlermeldungen oder zeigte nichts. Der Grund war, dass ich die Zeit, in der Hanna mit ihrem Rücken zu kämpfen hatte, dafür nutzen wollte, dieses Blog auf die neuste Version 2.9 von WordPress updaten wollte. Normalerweise habe ich früher gemeint „Never change a running system“. Aber mit den Sicherheitslücken im Internet habe ich es mir angewöhnt, alle Updates zügig durchzuführen.

Nun ist das Update von WordPress eigentlich einfach geworden, aber die Version 2.9 verlangt eine neuere MySQL-Datenbank als die, die ich seit Jahren nutze. Kein Problem dachte ich mir, richte ich mir eine neue DB ein bei meinem Provider mit der erforderlichen Version. Gesagt getan, das ist ja schwer, zwei Datenbanken stehen mir zur Verfügung, eine hatte ich nur genutzt bisher. Nur gelang es mir nicht, meine Sicherung von der 4er Version auf die 5er aufzuspielen, weder die mit wp-backup erstellte Sicherung, noch den MySQL-Dump, es kam immer zu Fehlern.

Und wie das so ist mit dem Basteln, ging dann zwischendurch noch die alte Version kaputt und ich brauchte einige Stunden, um alles wieder gangbar zu machen. Nun, wie es aussieht, läuft zumindest die Version 2.8.6 wieder, zum Glück.

Wenn jemand hilfreiche Tipps hat, was ich besser machen könnte, bin für alles Nützliche dankbar. Und die nicht mit der Technik versierten Leser bitte ich, mir diesen doch sehr ins Spezielle gehenden Artikel nachzusehen.

Post to Twitter Post to Delicious Post to Digg Post to Facebook

Dieser Beitrag wurde unter Hobbyraum veröffentlicht. Setze ein Lesezeichen auf den Permalink.

4 Kommentare zu Upgrade gescheitert

  1. Mike sagt:

    beim exportieren der alten alten 4.x solltest du darauf achten, das die Option “ komplette Inserts verwenden “ oder ähnlich klingend ( je nach Tool ) gesetzt ist , dann klappt es auch mit dem Import in die 5.x

  2. Axel sagt:

    Danke für den Tipp, hat aber auch nicht funktioniert. Irgendwo ist der Wurm drin, beim Import kommt irgendwann die Meldung: „Kein SQL-Befehl“. Mal sehen, was der Support sagt.

  3. Mike sagt:

    das klingt nach einem Sonderzeichen was nicht richtig in hochkommatar gesetzt wurde .. haste den insert bei dem das passiert ?

  4. Axel sagt:

    Nein, leider nicht, nur den kompletten Dump und der ist ein bisschen groß.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.